MySQL Forums
Forum List  »  MySQL Workbench

Re: Workbench update query unresponsive
Posted by: Gideon Engelbrecht
Date: August 19, 2022 02:23AM

Peter maybe these observations can help you :

From the query update test set Test_col1 = 'Test';

I am trying to input a string into an integer value. No warnings
0 row(s) affected Rows matched: 0 Changed: 0 Warnings: 0

If I try update test set Test_col1 = 7; I get 0 row(s) returned

If I insert a record manually in workbench via the result grid and apply changes, then run the above query, I get the expected result. If I run the first query (with text) I get the output : Error Code: 1366. Incorrect integer value: 'Test' for column 'Test_col1' at row 1 - which is what I would expect.


When I run : delete from test; ALTER TABLE test AUTO_INCREMENT = 1; When I run any of the above queries the result is the same as my initial question. No warning and all values are NULL.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Workbench update query unresponsive
52
August 19, 2022 02:23AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.