MySQL Forums
Forum List  »  MySQL Workbench

Re: MySQLWorkbench quit unexpectedly crashes
Posted by: Michael Weintraub
Date: January 25, 2023 05:40PM

I had the same problem. I also downgraded, which solved the crashing issue - thank you.

But, workbench cannot show the details of any schema, which makes it hard to use. Below are my attempts to remedy the situation.

I'm running MacOS Ventura 13.1 on a brand new M1-based pro. I had been on windows, and workbench/MySQL worked fine there. I'm running the latest mySQL CE. I'm using XAMPP to manage everything, but I'm not tied to it. I don't remember what I used before, but it would have been the latest versions from around last June.

I'm looking for suggestions for tools to load data. In windows, before my dell gave up the ghost, I used workbench to read a lot of csv's of varying lengths and populate the static parts of the database. I'm using django to generate the schema, so my needs are more around working with altering or creating the data outside of the framework. Workbench is nice because it's flexible about column names, orders, and notions of complete records.

If workbench can be fixed, great (I'm not finding the solution given my searches). If not, are there any tools for loading csv's into mySQL that folks recommend?

I guess I could write my own reader a python package. My sql isn't as strong as it once was. I would prefer not to run a windows vm either.


I get the dreaded Tables could not be fetched,... because
Error Code: 1558 Column count of mysql.proc is wrong. Expected 21, found 20. Created with MariaDB 100108, now running 100427. Please use mysql_upgrade to fix this error

I've tried sql_update. Then I get the response that this is not needed because it's now built in.

I've tried reverse engineering the connection. Workbench dies on the last step: import table objects. It doesn't matter if I include or exclude objects. This behavior is reliable. It does seem the 130 objects that django created.

Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000000
Exception Codes: 0x0000000000000001, 0x0000000000000000

Termination Reason: Namespace SIGNAL, Code 11 Segmentation fault: 11
Terminating Process: exc handler [15419]

Lots of people share this.

I've walked workbench versions. This example comes from v 8.0.29. I can keep walking backwards, but this seems to be perhaps moot.

I've tried a couple of other suggestions from stackoverflow as well. Several ended up forcing me to reload mySQL, which means a bit of work once it's reloaded.

Options: ReplyQuote

Written By
Re: MySQLWorkbench quit unexpectedly crashes
January 25, 2023 05:40PM
January 24, 2023 08:42PM
January 24, 2023 08:45PM

Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.