MySQL Forums
Forum List  »  Data Recovery

Data restore failure
Posted by: John Peterson
Date: October 12, 2010 02:56PM

I was running MySQL Server CE v5.0.51b on Windows XP and wanted to upgrade to the newer v5.1.51, so I created backups of each of my catalogs using MySQL Administrator v1.2.12.

I then installed the newer server and tried to restore each of my catalogs, again using MySQL Administrator. All of the backup files restored successfully but one. I used the 'analyze file content' and it was successful, but when I try to restore it, it is unsuccessful. Figuring it may be an incompatibility with the newer server version, I reverted back to v5.0.51a (I couldn't find v5.0.51b). However, I got the same results when I tried to restore the one file.

Any ideas on why the one file successfully analyzed but would not restore? Is there another way to recover my data?

Any help would be greatly appreciated!

Further details:

The backup file in question is a catalog of the schema for Atlassian Confluence (http://www.atlassian.com/software/confluence/).

I get the following errors when I try to restore it:

Error while executing this query:INSERT INTO `plugindata` (`PLUGINDATAID`,`PLUGINKEY`,`FILENAME`,`LASTMODDATE`,`DATA`) VALUES
(12288001,'com.atlassian.studio.confluence-streams-servlet','downloadedPlugin.B3BL7m2tWvtUeF0WSMOq.confluence-streams-servlet-1.2.3.jar','2009-08-08 14:12:55',0x504B...),
(12288002,'org.panko.confluence.oo-extractor-plugin','downloadedPlugin.QtCgGObhmfFe056aRbQm.oo-extractor-plugin-1.0.1.jar','2009-08-08 14:13:39',0x504B...),
(14221313,'confluence.extra.chart','downloadedPlugin.46hgWqexEysiKBzI51TU.790.jar','2009-08-25 21:45:14',0x504B...),
The server has returned this error message:MySQL server has gone away
MySQL Error.

Options: ReplyQuote


Subject
Views
Written By
Posted
Data restore failure
3134
October 12, 2010 02:56PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.