MySQL Forums
Forum List  »  Data Recovery

Restore large database ERROR 5 (HY000)... Out of memory
Posted by: Justin Yaple
Date: January 05, 2011 02:17PM


I am in the process of moving my databases to a new server. The original was a mysql 4.0.x and I dumped a backup using.
mysqldump -uroot --password='*' --all-databases --allow-keywords --add-drop-table --quick --quote-names >/var/lib/l1te/databasebackup.sql

The file is about 130GB.

The new server is mysql 5.1.51 but when I tried to restore the database I keep getting this out of memory error.
mysql -uroot --password='*' --quick --unbuffered < databasebackup.sql

I have tried to increase the memory in the system from 1GB to 2GB then to 4GB each time the backup gets further along but eventually errors stating it needs more memory that the time before.


Options: ReplyQuote

Written By
Restore large database ERROR 5 (HY000)... Out of memory
January 05, 2011 02:17PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.