MySQL Forums
Forum List  »  Data Recovery

Delimiter problem when restoring dump
Posted by: Joris AMATO
Date: March 06, 2014 09:14AM


I've a big problem when trying to restore a huge dump file.
This dump is made on a debian server with MySQL 5.5.27 with the following options :

The dumpfile is about 5Go.

When I'm trying to restore this dump on another debian server with MySQL 5.5.35, I have this error message :

ERROR 1310 (42000) at line 8255: End-label DELIMITER without match

I've tried to look for a solution on google, but there is absolutely no result for this error message. It's just like my dump file contain the string "DELIMITER" as delimiter, which is not.

At this line, I have "DELIMITER ;;", so the delimiter is set to ";;".
I tried to replace this delimiter by another, but it doesn't change anything, I have the exact same error message.

So I'm begging for help, I'm desesperate, how can I restore my dump file without weird error ?

Thank you,

PS : please excuse my english, I'm french, and like many french people, I'm not so good for foreign languages...


Options: ReplyQuote

Written By
Delimiter problem when restoring dump
March 06, 2014 09:14AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.