MySQL Forums
Forum List  »  Connector/C++

Problem with older MySQL Version 4.0.24
Posted by: Daniel Schlosser
Date: May 31, 2009 10:40AM

Hi,

I use the c++/Connector to access to a MySQL Database.
The database itself is version 4.0.24

When I try to connect to the database the Connector Libs throw an exception with error code 2049 or error message : "Connection using old (pre-4.1.1) authentication protocol refused (client option 'secure_auth' enabled)"

Are there any possibilities to work around this issue or is the only solution an update for the database.

The latter is not possible to do for me, because of certain specifications

Daniel Schlosser

Options: ReplyQuote


Subject
Views
Written By
Posted
Problem with older MySQL Version 4.0.24
6152
May 31, 2009 10:40AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.