MySQL Forums
Forum List  »  Connector/C++

Re: I need help with a build of mysql connector 8 test code which fails with symbols not found for architecture x86-64.
Posted by: Timothy Cerka
Date: January 03, 2020 07:53PM

Thanks Luis for the reply.

I had the library path in the project but not explicitly the lib. I explicitly added the library to the project and now we are much closer. The only problem is, now that the lib has been added, the linker can’t find it. Here is the output from the console:

18:29:21 **** Incremental Build of configuration Debug for project SQL_Test_1 ****
make all
Building target: SQL_Test_1
Invoking: MacOS X C++ Linker
g++ -L/repository_source_code/mysql/connector/mysql-connector-cpp-8.0.18/mysql-connector-cpp-8.0.18 -o "SQL_Test_1" ./main.o -l/repository_source_code/mysql/connector/mysql-connector-cpp-8.0.18/mysql-connector-cpp-8.0.18/libmysqlcppconn8-static.a
ld: library not found for -l/repository_source_code/mysql/connector/mysql-connector-cpp-8.0.18/mysql-connector-cpp-8.0.18/libmysqlcppconn8-static.a
clang: error: linker command failed with exit code 1 (use -v to see invocation)
make: *** [SQL_Test_1] Error 1

18:29:21 Build Finished (took 62ms)

Thanks for the help.

Tim

With Thanks

Tim Cerka

Mac Mini 2.5 GHz Intel Core i5
macOS Sierra v10.12.6

Eclipse IDE for C/C++ Developers
Version: Mars.1 Release (4.5.1)

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: I need help with a build of mysql connector 8 test code which fails with symbols not found for architecture x86-64.
309
January 03, 2020 07:53PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.