Not able compile using Oralce enterprise backup utility
Posted by: Pavan Kulkarni
Date: November 19, 2011 05:26AM

Hi,

Setup details:
--------------

I have moved the DB to a mounted LUN i.e. from /var/lib/mysql to /mnt/tmp/mysql, on linux OS.
From mysqldump, upgraded to oracle enterprise MySQL backup utility.

Using the same backup utility we are developing a 'C' module for backup.
But I am not able to compile the code. I am getting the error as when I compile as below

[root@rhel5p pavan]# gcc -g -o load load_images.c `mysql_config --cflags --libs`
/usr/bin/ld: cannot find -lmysqlclient

When I tried to modify the header files path as
#include </usr/include/mysql/my_global.h>

Still I am getting same error.

My Suspect is, as I have moved the database to mounted LUN, So it will be looking for the files in the standard path.
Please let me know if any workaround or solution for the issue I am facing.

Please let me know if any other details required

Thanks
Pavan

Options: ReplyQuote


Subject
Views
Written By
Posted
Not able compile using Oralce enterprise backup utility
1226
November 19, 2011 05:26AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.