MySQL Forums
Forum List  »  MySQL for Excel

MySQL for Excel Error 1253 when committing
Posted by: Yves Gattegno
Date: November 15, 2016 07:57PM

Hello

Several persons have reported an error when committing with MySQL for Excel in "Edit MySQL Data" mode.

The error says:
MySQL Error 1253:
COLLATION 'utf8_general_ci' is not valid for CHARACTER SET 'latin1'

But in some case, this message is just wrong: you can commit certain values and you can't commit some other values. This should not be the case if this was a real "encoding" error.

I nailed it down to the fact that this error appears WHENEVER a row has a value which length is greater than 48 characters...

Try it with this table:
CREATE TABLE IF NOT EXISTS `DBG3` (
`ID` int(11) NOT NULL,
`TEXT` varchar(256) DEFAULT NULL,
PRIMARY KEY (`ID`)
) ENGINE=InnoDB DEFAULT CHARSET=utf8;


INSERT INTO `DBG3` (`ID`, `TEXT`) VALUES
(1, '0123456789abcdef0123456789abcdef0123456789abcde');

Connect MySQL to a server that has this table.
Use Edit MySQL Database
Edit the "TEXT" value of this table.
As soon as it has a length greater than 48 characters, you may get the error (I do all the times).

I commented on a bug report that was describing exactly this behaviour, and the bug is now re-opened:
https://bugs.mysql.com/bug.php?id=76287

I am sorry that I had not nailed it down to this very issue before I started commenting (so you'll have the leads of my thoughts almost "live"), but I eventually described the 48 character issue (related to the use of @OldColXXValue in the request I think).

I hope the bug will be corrected soon.

Regards

- Yves

Options: ReplyQuote


Subject
Views
Written By
Posted
MySQL for Excel Error 1253 when committing
620
November 15, 2016 07:57PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.