MySQL Forums :: MySQL for Visual Studio :: Can't create datasource on VS2015


Advanced Search

Can't create datasource on VS2015
Date: July 28, 2016 05:10AM

Hello all,

I have a problem while trying to create a MySQL data source in Visual Studio 2015 Community.

Here's what I do:

On a new project, I click "Add a new Data Source"

on the following screen, I select "database", then "dataset".

On the screen to select the data connection, I create a connection (or use the one already in the server explorer, it doesn't matter), up until this point everything works, the test connection goes ok.

On the screen that asks me to select the database objects, I select the tables, and when I hit Finish, it produces this error: "Some updating commands could not be generated automatically. The database returned the following error: you have a usable connection already".

What am I doing wrong?

The connection in Server Explorer Works ok, I can see the database, its tables, its columns, I can work with it within the code, but I just can't create a data source.

My environment here is
Windows 10
Visual Studio 2015 Community
MySQL for Visual Studio 1.2.6 (I already tried the 2.0.3 also, same result)
Connector/Net 6.9.9

Thank you!

Options: ReplyQuote


Subject Views Written By Posted
Can't create datasource on VS2015 1798 Guilherme Groke Guilherme 07/28/2016 05:10AM
Re: Can't create datasource on VS2015 778 Jose Astorga 07/28/2016 05:39AM
Re: Can't create datasource on VS2015 800 MIke Smith 07/29/2016 11:19AM
Re: Can't create datasource on VS2015 631 Brian Scanlon 07/28/2016 10:07AM
Re: Can't create datasource on VS2015 560 Thomas Rengot 07/29/2016 07:52AM
Re: Can't create datasource on VS2015 509 Javier Martinez 07/30/2016 04:04PM
Re: Can't create datasource on VS2015 496 Javier Martinez 07/31/2016 07:44AM
Re: Can't create datasource on VS2015 574 Fran Montserrat 08/02/2016 07:32PM
Re: Can't create datasource on VS2015 490 Javier Martinez 08/03/2016 01:57AM
Re: Can't create datasource on VS2015 433 Guilherme Groke Guilherme 08/03/2016 04:39AM
Re: Can't create datasource on VS2015 442 Javier Martinez 08/03/2016 04:54AM
Re: Can't create datasource on VS2015 450 Fran Montserrat 08/03/2016 06:48AM
Re: Can't create datasource on VS2015 455 Fran Montserrat 08/03/2016 07:12AM
Re: Can't create datasource on VS2015 428 Javier Martinez 08/03/2016 07:56AM
Re: Can't create datasource on VS2015 468 Guilherme Groke ggroke 08/03/2016 08:48AM
Re: Can't create datasource on VS2015 438 Javier Martinez 08/03/2016 02:00PM
Re: Can't create datasource on VS2015 424 Fran Montserrat 08/08/2016 05:29AM
Re: Can't create datasource on VS2015 420 Javier Martinez 08/08/2016 02:14PM
Re: Can't create datasource on VS2015 520 Guilherme Groke ggroke 08/08/2016 02:20PM
Re: Can't create datasource on VS2015 519 Javier Martinez 08/08/2016 02:26PM
Re: Can't create datasource on VS2015 2610 Francisco Alberto Tirado Zavala 08/15/2016 10:55AM
Re: Can't create datasource on VS2015 737 Francisco Alberto Tirado Zavala 08/15/2016 11:03AM
Re: Can't create datasource on VS2015 588 Javier Martinez 08/15/2016 11:34AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.