MySQL Forums
Forum List  »  MySQL for Visual Studio

Can't create datasource on VS2015
Posted by: Guilherme Groke Guilherme
Date: July 28, 2016 05:10AM

Hello all,

I have a problem while trying to create a MySQL data source in Visual Studio 2015 Community.

Here's what I do:

On a new project, I click "Add a new Data Source"

on the following screen, I select "database", then "dataset".

On the screen to select the data connection, I create a connection (or use the one already in the server explorer, it doesn't matter), up until this point everything works, the test connection goes ok.

On the screen that asks me to select the database objects, I select the tables, and when I hit Finish, it produces this error: "Some updating commands could not be generated automatically. The database returned the following error: you have a usable connection already".

What am I doing wrong?

The connection in Server Explorer Works ok, I can see the database, its tables, its columns, I can work with it within the code, but I just can't create a data source.

My environment here is
Windows 10
Visual Studio 2015 Community
MySQL for Visual Studio 1.2.6 (I already tried the 2.0.3 also, same result)
Connector/Net 6.9.9

Thank you!

Options: ReplyQuote

Written By
Can't create datasource on VS2015
July 28, 2016 05:10AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.