MySQL Forums
Forum List  »  MySQL for Visual Studio

Re: Cannot Create New Datasource
Posted by: Kai Neumann
Date: December 07, 2017 01:26AM

Hi,

I had the same problem and also tried different variants 1.2.6/1.2.7/2.0.4/2.0.5 with 6.9.8/6.9.9/6.9.10/6.9.10/6.10.x.

Finally I managed to get the combination 2.0.5 with 6.9.9 to run. I don't know why, because I mean, I have tried the combination before already unsuccessfully....

My successful path:
* uninstall the Connector and MySQL for VS
* reboot
* install MySQL for VS as a single package (manually download - not via the MySQL installer) and select the customized installation. Uncheck everything that has nothing to do with VS2017 (VS2013 and so on)
* Install the Connector as a single package (download it manually - not via the MySQL installer)
* reboot
* start VisualStudio, create a new project and create a new dataset - do not create a data source!
Instead, use the Server Explorer to add a new connection. Drag a table from the created data connection in the Server Explorer into the DataSet with Drag' n' Drop. After that I had a new data source, which I could adjust with the data wizard (right mouse button) and transfer further tables into the dataset.

That's all I've tested, but I'm glad it seems to be working.

Options: ReplyQuote


Subject
Views
Written By
Posted
49
December 05, 2017 03:41PM
Re: Cannot Create New Datasource
24
December 07, 2017 01:26AM
15
December 07, 2017 02:06PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.