MySQL Forums
Forum List  »  MySQL for Visual Studio

Visual Studio 2017 error during build:"MySql.Data, Version=8.0.11.0" could not be resolved because it was built against the ".NETFramework,Version=v4.5.2" framework.
Posted by: Ashish Ghimire
Date: May 05, 2018 06:42AM

Hi all,

I've used the latest installer and installed MySQL for Visual Studio (1.2.8) and Connector/Net 8.0.11. I'm using Microsoft Visual Studio Community version 15.5.6 (.NET framework 4.7.02556).

I've added the connection to MySQL using the server explorer and run some scripts, no problems. However, when I add a reference to MySQL.Data.dll and try and execute some SQL using C#, I get the message below. Is this a known issue/bug? Any workarounds?

The primary reference "MySql.Data, Version=8.0.11.0, Culture=neutral, PublicKeyToken=<token>, processorArchitecture=MSIL" could not be resolved because it was built against the ".NETFramework,Version=v4.5.2" framework. This is a higher version than the currently targeted framework ".NETFramework,Version=v4.5".

Options: ReplyQuote


Subject
Views
Written By
Posted
Visual Studio 2017 error during build:"MySql.Data, Version=8.0.11.0" could not be resolved because it was built against the ".NETFramework,Version=v4.5.2" framework.
1626
May 05, 2018 06:42AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.