MySQL Forums
Forum List  »  MySQL for Visual Studio

Re: Visual Studio 2017 error during build:"MySql.Data, Version=8.0.11.0" could not be resolved because it was built against the ".NETFramework,Version=v4.5.2" framework.
Posted by: JOSE RAMIREZ
Date: May 18, 2018 10:58AM

Hello Ashish,

thank you for posting your question in the MySQL for Visual Studio forum. This is because your project is targeting .NET 4.5 while MySql.Data.dll requires .NET 4.5.2. To fix it you would need to make your project target .NET 4.5.2 following below steps:

1. Go to the project's properties (right click the project in the Solution Explorer and select the Properties option).
2. In the Application tab look for the Target Framework option. Select ".NET 4.5.2" or higher.


Note that MySQL for Visual Studio and MySQL Connector/NET are two separate products. When it comes to coding in C# to access MySQL databases you are actually making use of MySQL Connector/NET, ideally you can post questions related to coding in their forum to get a more specialized reply.

Regards.


====================================
Jose Maria Ramirez
MySQL Windows Experience Team

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Visual Studio 2017 error during build:"MySql.Data, Version=8.0.11.0" could not be resolved because it was built against the ".NETFramework,Version=v4.5.2" framework.
672
May 18, 2018 10:58AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.