MySQL Forums
Forum List  »  MySQL for Visual Studio

Re: Entitiy Framework Wizard crashes
Posted by: Christian Filippi
Date: June 27, 2018 09:58AM

I don't know why these tools are so picky.
I can say how i had my generation working,
i followed a way from a website (Can i paste here the link?)
However, the "working recipe" to have it working seems to be this one:

Install "MySQL for Visual Studio" v2.0.5 CTP (MySQL for Visual Studio). Note: Install MySQL for Visual Studio before Connector/NET.
Install "Connector/NET" v6.9.10 (Connector/Net) Note: I tried using Connector/NET v6.8, v6.10 and v8 first, but none of them worked with Visual Studio 2017.
Create new Visual Studio Professional 2017 project.
Download and Install "EntityFramework" v6.2.0 through NuGet, by going to Project Tab/Manage NuGet Packages/Browse -> Entity Framework.
Add references to C:\Program Files (x86)\MySQL\Connector.NET 6.9.10\Assemblies\v4.5\MySql.Data.dll and C:\Program Files (x86)\MySQL\Connector.NET 6.9.10\Assemblies\v4.5\MySql.Data.Entity.EF6.dll; by Right Clicking over References inside Solution Explorer and selecting Add Reference/Browse ->Browse button.
Add MySQL EF6 provider info inside App.config under entity framework providers as follow:
<provider invariantName="MySql.Data.MySqlClient"
type="MySql.Data.MySqlClient.MySqlProviderServices, MySql.Data.Entity.EF6" />

Rebuild project by going to Build tab/Rebuild ProjectName.


This worked for me, but i'm stuck anyway because i can't get the dataset generation working and seems that nobody knows about.
Hope it helps

Options: ReplyQuote

Written By
June 27, 2018 06:51AM
Re: Entitiy Framework Wizard crashes
June 27, 2018 09:58AM
October 08, 2018 11:36AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.