MySQL Forums
Forum List  »  InnoDB clusters

Mysql 8 group replication sync problem
Posted by: Peter Hutchison
Date: June 19, 2019 04:55AM

I have mySQL 8.0.16 with a Innodb cluster configured with 3 servers.
I backed up a DB with mysql dump, removed the database and created a new database, and tried reimported the database again from sql file on to the R/W master instance.

The first time I tried I got this error:
ERROR 13176 (HY000) at line 24: Cannot update GTID_PURGED with the Group Replication plugin running

So the DB was created but no tables imported.

I tried again using the mysql 'source filename' command and got this error:
"ERROR 3546 (HY000): @@GLOBAL.GTID_PURGED cannot be changed: the added gtid set must not overlap with @@GLOBAL.GTID_EXECUTED

So it seems not possible to restore the databases using normal mysqldump, and mysql command method.

One of the R/O instances is now out of sync, it still shows the empty database in the list and I cannot seem to force the instance to sync with the master properly. I played about with 'reset master' and gtid_purged variables with no look.

Is there any good instructions on getting replication working again in innodb group replication? Or would it be best to rebuild mysql again on the mysql instance to fix it?

Options: ReplyQuote


Subject
Views
Written By
Posted
Mysql 8 group replication sync problem
1869
June 19, 2019 04:55AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.