MySQL Forums
Forum List  »  InnoDB clusters

Re: Group Replication doesn't like "::ffff:" as an IP Address
Posted by: Krzysztof Wróblewski
Date: December 17, 2019 01:45AM

I had similar issue...
Here my notes:

As documentation says:

AUTOMATIC mode should authorize automatically

IPv4 (as defined in RFC 1918)
10/8 prefix ( - - Class A

But when ipv6 comes... there is no rule for ::ffff:...
I couldn't switch listener 33061 to ipv4 (which comes with GR) on CentOS 8. It was always triggerred on ipv6.

Even when you add whitelist to node no.1 during creation
dba.createCluster('mycluster',{ipWhitelist: ''})
it doesn't propagate this whitelist through all nodes (and it could be).

You have to add it manually through all nodes (even for private network) by :
cluster.addInstance('cluster@mysql02',{ipWhitelist: ''})

If you don't do this, you will have error like in this topic.

Edited 1 time(s). Last edit at 12/17/2019 01:48AM by Krzysztof Wróblewski.

Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.