MySQL Forums :: General :: [SOLVED] DATETIME does not keep fractional seconds (5.6.11)


Advanced Search

[SOLVED] DATETIME does not keep fractional seconds (5.6.11)
Posted by: P THE AWESOME ()
Date: December 28, 2013 10:16PM

No matter how I query the MySQL server (phpMyAdmin, NodeJS, or the Workbench) it rounds accordingly and then replaces my fractional seconds with zeros or just omits them. I am using MySQL Community Server 5.6.11 (which is greater than 5.6.4 when fractional seconds support was added).

Some more info about my server:

- Server version: 5.6.11-log - MySQL Community Server (GPL)
- Protocol version: 10
- Server charset: UTF-8 Unicode (utf8)
- Windows 8 Pro x86
- MySQL Workbench 6.0.8.11354 build 883 (Community)



NOTE: When viewing the table in phpMyAdmin, it shows all zeros for the fractional seconds. In the MySQL Workbench, it just omits them and only shows up to the second.

Thanks!



Edited 1 time(s). Last edit at 12/29/2013 02:42PM by P THE AWESOME.

Options: ReplyQuote


Subject Written By Posted
[SOLVED] DATETIME does not keep fractional seconds (5.6.11) P THE AWESOME 12/28/2013 10:16PM
Re: DATETIME does not keep fractional seconds (5.6.11) Peter Brawley 12/28/2013 11:02PM
Re: DATETIME does not keep fractional seconds (5.6.11) P THE AWESOME 12/29/2013 11:20AM
Re: DATETIME does not keep fractional seconds (5.6.11) Peter Brawley 12/29/2013 02:03PM
Re: DATETIME does not keep fractional seconds (5.6.11) P THE AWESOME 12/29/2013 02:42PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.