MySQL Forums
Forum List  »  General

Using functions from other shared library in UDF
Posted by: Marcin Dzieszko
Date: December 12, 2017 10:02AM


I'm new to UDF and MySQL :-).

I faced the following problem:

I created UDF and compiled to so library (under Linux).
My UDF calls functions from the other shared object (

When issuing 'CREATE FUNCTION' with my UDF it returns:
'undefined symbol' for any function from called in my UDF.

Is there a way how to make MySQL load the other .so as well and make it works?

What I checked:

1) I tried make librpm.a (static archive) from - could not. I don't have sources to this. Also I could not found package with librpm.a.
2) I put to MySQL plugin directory - didn't help.
3) I tried: install soname 'librpm'; Ir returned: Can't find symbol '_mysql_plugin_interface_version_' in library.

For now I don't have idea hw to resolve it,

Thanks for help in advance,
Marcin Dzieszko

Options: ReplyQuote

Written By
Using functions from other shared library in UDF
December 12, 2017 10:02AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.