MySQL Forums
Forum List  »  General

can't enable jemalloc : 5.7.30
Posted by: Andrew Poodle
Date: February 22, 2021 05:42AM

Attempting to use jemalloc for mysql 5.7.30

Linux db1 4.18.0-193.6.3.el8_2.x86_64 #1 SMP Wed Jun 10 11:09:32 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux

MySQL 5.7.30

yum list installed shows: jemalloc.x86_64 5.2.1-2.el8 @epel

jemalloc file evident in /usr/lib64/libjemalloc.so.2

Adding...

[mysqld-safe]
malloc-lib=/usr/lib64/libjemalloc.so.2
...to my.cnf returns an "unknown variable" error for malloc-lib

Setting

[Service]
Environment="LD_PRELOAD=/usr/lib64/libjemalloc.so.2"
in the systemctl override file doesn't change anything

Manually doing

export LD_PRELOAD=/usr/lib64/libjemalloc.so.2

prior to a restart doesn't have any effect either.

What am I missing?

Options: ReplyQuote


Subject
Written By
Posted
can't enable jemalloc : 5.7.30
February 22, 2021 05:42AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.