MySQL Forums
Forum List  »  General

Mysqldump 8.0.23 mysqldump error
Posted by: Christos Petritzis
Date: April 12, 2021 12:05AM

Hi! I have an Ubuntu Web Server with latest version 20.04. My mysql version is also the latest 8.0.23. I have a problem with auto mysqldump.
My Backup user has those privilleges: SELECT, TRIGGER, SHOW VIEW, LOCK TABLES and PROCESS
This procedure worked for me until Mysql 5.7 version.
First i run this commant : mysql_config_editor set --login-path=local --host=localhost --user=username --password to make the .mylogin.cnf
and after that i run mysqldump --login-path=local my_database | gzip > db_backup.tar.gz
Either as root either as backup user i have this error: ERROR 1045 (28000): Access denied for user 'myuser'@'localhost' (using password: YES)

P.S. when i'm trying with root user i reproduced again the .mylogin.cnf file with correct credentials.

Thank you Very Much

Options: ReplyQuote


Subject
Written By
Posted
Mysqldump 8.0.23 mysqldump error
April 12, 2021 12:05AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.