MySQL Forums
Forum List  »  MyISAM

Got error 124 from storage engine
Posted by: Eric George
Date: February 16, 2010 12:44PM

Ok, I've got issues.
I'm getting the above error on insert to my database. It's MySQL 4.1.22 on a RedHat Enterprise 4.0 box. I'm using MyISAM tables.

The table in question has about 19 million records and is part of a merge table with a much larger compressed archive table. This configuration has been working fine for years, with no recent changes.

Despite this error on insertion, the insert appears to complete successfully - my row count goes up, I can query against it (the actual table, and the merge table) and get reasonable results, etc. If I run a check table on this table I get the following:

+-----------------+-------+----------+---------------------------------------------------------------+
| Table | Op | Msg_type | Msg_text |
+-----------------+-------+----------+---------------------------------------------------------------+
| my_db.my_active | check | error | Size of datafile is: 5184194948 Should be: 5184541472 |
| my_db.my_active | check | error | Corrupt |
+-----------------+-------+----------+---------------------------------------------------------------+

If I run a repair table against it, it will tell me it is repaired, and a subsequent check table returns that it's OK. But the same thing happens again on the next insert.

So I tried dumping the table with mysqldump, and then rebuilding it from the dump. Again, the new table looks fine - but as soon as I attempt to insert, I get the same error again??

I found some reference to index size issues when googling this error message. The size of the MYI file on disk is about 824MB - much smaller then some others. There are 4 indexes on the table - one is an auto-increment primary key, two others are single column non-unique indexes, and one is a 3 column unique index involving two ints and a double.

Options: ReplyQuote


Subject
Views
Written By
Posted
Got error 124 from storage engine
8225
February 16, 2010 12:44PM
2881
February 18, 2010 04:25PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.