MySQL Forums
Forum List  »  MyISAM

ERROR 126 (HY000): Incorrect key file for table
Posted by: Jean-Paul Le Fèvre
Date: October 19, 2005 12:29PM

I'm stuck with "ERROR 126 (HY000): Incorrect key file for table" ...

I've a production database located on one machine.
On a regular basis I run mysqldump to get the current content into
a sql file.

I have a backup linux machine hosting the backup database. Using the
generated sql script I create a copy of the tables.

Unfortunately, at this point, this procedure fails. It used to work
some weeks ago but, now, the backup copy no longer works for 4 tables.
But it is still successful for the 20 others.

Using "myisamchk -r" does not help since, once repaired, the tables have
not the correct number of rows.

I've upgraded the server from mysql-5.0.4 to mysql-max-5.0.13 but it has
no effect. The OS is 2.4.20 with glibc 2.2.

I've tried "select * into outfile" followed by a "load data infile"
but the problem remains ("ERROR 126 ...")

However the same procedure used on another computer works correctly as
expected. This computer has a mysql-max-5.0.12 version running on
a linux 2.6.9 with a glibc 2.3.

I've googled a lot, perused the forums but without finding something useful.

Options: ReplyQuote


Subject
Views
Written By
Posted
ERROR 126 (HY000): Incorrect key file for table
57160
October 19, 2005 12:29PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.