MySQL Forums
Forum List  »  MyISAM

Re: Working with short words in full text search
Posted by: Rick James
Date: October 27, 2012 12:08PM

There are (at least) 3 restrictions in MyISAM's FULLTEXT:
* ft_min_word_len = 4
* stopwords
* not indexing any word that occurs in more than 50% of the rows.

You are asking about the first (but you may be tripping over stopwords, too.) You can change that setting in my.cnf (my.ini), however you need to do these to have it take effect:
1. restart mysqld
2. rebuild any existing FULLTEXT indexes (else they will continue to use "4"): This should suffice (for each table): ALTER TABLE foo ENGINE=MyISAM;

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Working with short words in full text search
1534
October 27, 2012 12:08PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.