MySQL Forums
Forum List  »  MyISAM

Enable Keys use keycache with "errorno 0" - 800Million Rows in one partition - 5 index
Posted by: Emmanuel Vincent
Date: October 31, 2012 08:27AM

Hi all,

I have the following issue

I use mySQL version 5.5.14 , Linux Redhat 64 bits

I Would like to use "Repair by sorting" instead of "repair by keycache"
but I can't success

When I perform "Alter table MyTable enable keys" In log I always see this:
[Warning] Warning: Enabling keys got errno 0 on MyBase.Mytable, retrying
And then the repair is done with KeyCache

my.cnf is like this:
- myisam-sort-buffer-size=16G => I've tried also with 32G/64G
- key_buffer_size=16G => I've tried also with 32G
- myisam-max-sort-file-size=90G ==> file system has 100G

I have tried "myisamchk -r" and it works well "with sort" but it isn't what I want to use moreover it is not supported for partition.

I want to use "Alter Table..."

After repair is finish
Partition Table File size is on disk : 25G
Partition Index File size is on disk :
- 8G "with sort using myisamchk -r"
- 16G with keycache using "Alter table..."

(for information i have also tried with thread and it works well but it is beta code.)

same issue whether I do "Repair table" I can see "Keycache" but I haven't any error in logs

Finally I have 32 hours using "Repair Keycache" and 1 hour using "Repair by Sort"

Any help would be great

Edited 6 time(s). Last edit at 11/02/2012 05:21AM by Emmanuel Vincent.

Options: ReplyQuote

Written By
Enable Keys use keycache with "errorno 0" - 800Million Rows in one partition - 5 index
October 31, 2012 08:27AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.