MySQL Forums
Forum List  »  InnoDB

Re: ERROR 1005: Can't create table (errno: 150) :: InnoDB
Posted by: Gary machol
Date: April 21, 2010 04:55AM

Well, I had a similar problem, the solution was to check the case.
I was running it on Windows and even Red Hat, worked fine.
But on Ubunto no.

the problem was that the referenced table was written, say, create table abc
and in the referencing tablde it was written constraint FK_blah foreign key (id) references ABC (id).
Changing the latter from ABC to abc fixed the problem.

Options: ReplyQuote


Subject
Views
Written By
Posted
655678
March 24, 2005 01:20PM
10086
October 09, 2012 09:48PM
4642
December 19, 2011 10:13PM
Re: ERROR 1005: Can't create table (errno: 150) :: InnoDB
9168
April 21, 2010 04:55AM
10810
May 09, 2006 06:01PM
13530
November 15, 2006 02:05PM
8439
T D
February 01, 2008 06:47AM
10764
August 27, 2008 08:08AM
11861
December 03, 2008 10:15AM
7109
May 01, 2009 07:39AM
4413
August 29, 2011 04:46PM
6016
s l
December 15, 2009 01:48PM
7276
December 22, 2009 02:54AM
5871
February 18, 2011 08:55AM
8430
May 24, 2011 10:11AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.