MySQL Forums
Forum List  »  InnoDB

Re: ERROR 1005: Can't create table (errno: 150) [SOLUTION]
Posted by: Mahesh Raju
Date: May 11, 2010 03:36AM

I was also getting the same error message. On checking the MYSQL reference, I figured it out that it is due to not having the foreign key field and the other filed having exact type. In my chase one was int and another was varchar.

Options: ReplyQuote


Subject
Views
Written By
Posted
655663
March 24, 2005 01:20PM
10081
October 09, 2012 09:48PM
Re: ERROR 1005: Can't create table (errno: 150) [SOLUTION]
14985
May 11, 2010 03:36AM
4638
December 19, 2011 10:13PM
10805
May 09, 2006 06:01PM
13524
November 15, 2006 02:05PM
8436
T D
February 01, 2008 06:47AM
10757
August 27, 2008 08:08AM
11858
December 03, 2008 10:15AM
7109
May 01, 2009 07:39AM
4412
August 29, 2011 04:46PM
6011
s l
December 15, 2009 01:48PM
7268
December 22, 2009 02:54AM
5868
February 18, 2011 08:55AM
8425
May 24, 2011 10:11AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.