MySQL Forums
Forum List  »  InnoDB

Re: ERROR 1005: Can't create table (errno: 150) :: InnoDB
Posted by: KimSeong Loh
Date: August 07, 2005 06:52PM

If you are using older version, before 4.1.? , then you need to create an index for the column used in the foreign key.

You need to add an index for (claimNo) in your employeeClaim table.

Also, make sure you have index on
employee (employeeID) and
claims (claimNo)
in the 2 other tables you referenced.

If this still does not work, then add also an index on (employeeID) in employeeClaim table, but I guess the Primary should be able to cover this one already. Note that your primary cannot cover the need of the index (claimNo).

Options: ReplyQuote


Subject
Views
Written By
Posted
652335
March 24, 2005 01:20PM
5909
October 09, 2012 09:48PM
4090
December 19, 2011 10:13PM
Re: ERROR 1005: Can't create table (errno: 150) :: InnoDB
23661
August 07, 2005 06:52PM
9657
May 09, 2006 06:01PM
8726
November 15, 2006 02:05PM
7785
T D
February 01, 2008 06:47AM
9778
August 27, 2008 08:08AM
10101
December 03, 2008 10:15AM
6534
May 01, 2009 07:39AM
3824
August 29, 2011 04:46PM
5487
s l
December 15, 2009 01:48PM
5353
December 22, 2009 02:54AM
3591
February 18, 2011 08:55AM
4339
May 24, 2011 10:11AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.