MySQL Forums
Forum List  »  InnoDB

Cannot open tables from the internal data dictionary
Posted by: Jason Carley
Date: December 13, 2008 08:42PM

I have moved from a linux mysql server to a windows mysql server. I copied the data directory from the linux machine to the windows machine. When i open a database in mysqladministrator that contains innodb tables they are not listed. I get the feeling MySQL isn't opening my ibdata1 file, but I've checked and re-checked that the data directory is correctly defined (is there another variable I should set?). If I run mysql in console mode I recieve the following output for each missing table when I access an impacted database:

[Error] cannot find or open table [db/table] from the internal data dictionary of InnoDB though the .frm file for the table exists. Maybe you have deleted the and recreated InnoDB data files but have forgotten to delete the corresponding .frm files of InnoDB tables, or you have moved .frm files to another database? or, the table contains indexes that this version of the engine doesn't support.

I tried using the force recovery setting at 4 and 6 - the tables still do not appear to exist in mysqladministrator.

Any help would be greatly appreciated! Thanks.

Options: ReplyQuote

Written By
Cannot open tables from the internal data dictionary
December 13, 2008 08:42PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.