MySQL Forums
Forum List  »  InnoDB

DB crashed help
Posted by: tony montana
Date: September 05, 2017 03:40PM

My VM ran out of disk space and MySQL wasn't able to write to the log file causing it to crash. I'm on mysql 5.6.

Here is the error_log file:

2017-09-05T11:47:00.636352Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M

2017-09-05T11:47:00.650903Z 0 [Note] InnoDB: Completed initialization of buffer pool

2017-09-05T11:47:00.654252Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().

2017-09-05T11:47:00.667475Z 0 [Note] InnoDB: Highest supported file format is Barracuda.

2017-09-05T11:47:00.669522Z 0 [ERROR] InnoDB: Ignoring the redo log due to missing MLOG_CHECKPOINT between the checkpoint 72827846847 and the end 72827846656.

2017-09-05T11:47:00.669553Z 0 [ERROR] InnoDB: Plugin initialization aborted with error Generic error

2017-09-05T11:47:01.270002Z 0 [ERROR] Plugin 'InnoDB' init function returned error.

2017-09-05T11:47:01.270053Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

2017-09-05T11:47:01.270064Z 0 [ERROR] Failed to initialize plugins.

2017-09-05T11:47:01.270071Z 0 [ERROR] Aborting

I've tried to remove the ib_log* file in /var/lib/mysql and set innodb_force_recovery = 3 in my.cnf file. But received the same error. Any help appreciated.

Thanks !

Options: ReplyQuote

Written By
DB crashed help
September 05, 2017 03:40PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.