MySQL Forums :: Performance :: my system usage hits 100% at every 6 hours.

Advanced Search

my system usage hits 100% at every 6 hours.
Posted by: mrugesh shah ()
Date: December 21, 2008 10:33PM


I am using VPS with one domain and one wordpress blog which uses mysql as database. Inside VPS, my "system usage" reaches to 100% at every 6 hours. I checked all. Earlier I thought that it may be script, plugin, site issue. But I removed all and tested by all means. Then I identified that it was mysql issue. Following is the process which consumes more memory :

/usr/sbin/mysqld --basedir=/ --datadir=/var/lib/mysql --user=mysql --pid-file=/var/lib/mysql/ --skip-external-locking --socket=/var/lib/mysql/mysql.sock

If I kill above process, my system usages becomes 40% from 100%. Even If I restart "mysql service" then also It becomes normal. At present I am controlling it through cron job but that is not final solution.

When system usage was 98%, I rune one tuninig-premier script and it give me following report :

- By: Matthew Montgomery -

MySQL Version 5.0.51a-community i686

Uptime = 0 days 5 hrs 57 min 3 sec
Avg. qps = 11
Total Questions = 236975
Threads Connected = 1

Warning: Server has not been running for at least 48hrs.
It may not be safe to use these recommendations

To find out more information on how each of these
runtime variables effects performance visit:
for info about MySQL's Enterprise Monitoring and Advisory Service

The slow query log is NOT enabled.
Current long_query_time = 10 sec.
You have 0 out of 237003 that take longer than 10 sec. to complete
Your long_query_time may be too high, I typically set this under 5 sec.

The binary update log is NOT enabled.
You will not be able to do point in time recovery

Current thread_cache_size = 128
Current threads_cached = 7
Current threads_per_sec = 0
Historic threads_per_sec = 0
Your thread_cache_size is fine

Current max_connections = 100
Current threads_connected = 1
Historic max_used_connections = 8
The number of used connections is 8% of the configured maximum.
You are using less than 10% of your configured max_connections.
Lowering max_connections could help to avoid an over-allocation of memory
See "MEMORY USAGE" section to make sure you are not over-allocating

Max Memory Ever Allocated : 75 M
Configured Max Per-thread Buffers : 417 M
Configured Max Global Buffers : 42 M
Configured Max Memory Limit : 459 M
Physical Memory : 512.00 M
Max memory limit seem to be within acceptable norms

Current MyISAM index space = 5 M
Current key_buffer_size = 16 M
Key cache miss rate is 1 : 1057
Key buffer fill ratio = 13.00 %
Your key_buffer_size seems to be too high.
Perhaps you can use these resources elsewhere

Query cache is enabled
Current query_cache_size = 16 M
Current query_cache_used = 9 M
Current query_cache_limit = 1 M
Current Query cache Memory fill ratio = 57.60 %
Current query_cache_min_res_unit = 4 K
MySQL won't cache query results that are larger than query_cache_limit in size

Current sort_buffer_size = 1 M
Current read_rnd_buffer_size = 1020 K
Sort buffer seems to be fine

Current join_buffer_size = 1.00 M
You have had 18 queries where a join could not use an index properly
You should enable "log-queries-not-using-indexes"
Then look for non indexed joins in the slow query log.
If you are unable to optimize your queries you may want to increase your
join_buffer_size to accommodate larger joins in one pass.

Note! This script will still suggest raising the join_buffer_size when
ANY joins not using indexes are found.

Current open_files_limit = 4096 files
The open_files_limit should typically be set to at least 2x-3x
that of table_cache if you have heavy MyISAM usage.
Your open_files_limit value seems to be fine

Current table_cache value = 1000 tables
You have a total of 134 tables
You have 149 open tables.
The table_cache value seems to be fine

Current max_heap_table_size = 64 M
Current tmp_table_size = 64 M
Of 9505 temp tables, 60% were created on disk
Perhaps you should increase your tmp_table_size and/or max_heap_table_size
to reduce the number of disk-based temporary tables
Note! BLOB and TEXT columns are not allow in memory tables.
If you are using these columns raising these values might not impact your
ratio of on disk temp tables.

Current read_buffer_size = 1020 K
Current table scan ratio = 161 : 1
read_buffer_size seems to be fine

Current Lock Wait ratio = 1 : 4154
You may benefit from selective use of InnoDB.
If you have a high concurrency of inserts on Dynamic row-length tables
consider setting 'concurrent_insert=2'.

Can anyone please guide me what is wrong with mysql process ?

Options: ReplyQuote

Subject Views Written By Posted
my system usage hits 100% at every 6 hours. 3445 mrugesh shah 12/21/2008 10:33PM
Re: my system usage hits 100% at every 6 hours. 1789 Rick James 12/22/2008 10:26PM
Re: my system usage hits 100% at every 6 hours. 1630 mrugesh shah 12/23/2008 11:40AM
update after 6 hours 1756 mrugesh shah 12/23/2008 07:20PM
Re: update after 6 hours 1555 Rick James 12/23/2008 10:16PM
logs and file details report 1718 mrugesh shah 12/23/2008 11:37PM
Re: logs and file details report 1625 Rick James 12/24/2008 10:57PM
Re: logs and file details report 1562 mrugesh shah 12/25/2008 01:23AM
Re: logs and file details report 1572 Rick James 12/26/2008 03:37PM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.