MySQL Forums :: Performance :: MySQL 5.1.36 on FreeBSD 7.2 amd64/i386 not honoring wait_timeout


Advanced Search

MySQL 5.1.36 on FreeBSD 7.2 amd64/i386 not honoring wait_timeout
Posted by: cruel symbol ()
Date: August 06, 2009 03:33AM

I installed mysql51-server from the ports.

# cd /usr/ports/databases/mysql51-server
# make -D BUILD_OPTIMIZED install clean

Added wait_timeout = 60 to my.cnf and restarted mysql but this is not reflected.

mysql> SHOW VARIABLES LIKE 'wait_%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| wait_timeout | 28800 |
+---------------+-------+
1 row in set (0.01 sec)


Then I tried setting it from mysql shell
mysql> set global wait_timeout = 30;
mysql> SHOW VARIABLES LIKE 'wait_%';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| wait_timeout | 28800 |
+---------------+-------+
1 row in set (0.01 sec)

MySQL 5.1 notes for FreeBSD says that this problem when using LinuxThreads and should be solved by FreeBSD 5.0. I'm using FreeBSD 7.2 and no LinuxThreads.

Any idea how to get past this.

Thanks

Options: ReplyQuote


Subject Views Written By Posted
MySQL 5.1.36 on FreeBSD 7.2 amd64/i386 not honoring wait_timeout 2913 cruel symbol 08/06/2009 03:33AM
Re: MySQL 5.1.36 on FreeBSD 7.2 amd64/i386 not honoring wait_timeout 1652 Rick James 08/07/2009 06:05PM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.