MySQL Forums
Forum List  »  Performance

Re: 1135 Can't create a new thread (errno 11)...
Posted by: Wagner Bianchi
Date: December 20, 2011 08:51AM

Rick,

On another customer, this morning, this error starts when they tried to connect via client interface (MySQL Workbench). This is not enough to know exactly what is happening, but, it seems that when MySQL reaches the top number of connections, something around 1008, it starts to reject new ones, increasing Aborted_Connects status variables.

mysql> show status like 'Aborted%';
+------------------+-------+
| Variable_name | Value |
+------------------+-------+
| Aborted_clients | 6551 |
| Aborted_connects | 5107 |
+------------------+-------+
2 rows in set (0.00 sec)


Now I am configuring limits.conf like this:


-bash-4.1$ ulimit -a
core file size (blocks, -c) 0
data seg size (kbytes, -d) unlimited
scheduling priority (-e) 0
file size (blocks, -f) unlimited
pending signals (-i) 192031
max locked memory (kbytes, -l) 64
max memory size (kbytes, -m) unlimited
open files (-n) 900000
pipe size (512 bytes, -p) 8
POSIX message queues (bytes, -q) 819200
real-time priority (-r) 0
stack size (kbytes, -s) 10240
cpu time (seconds, -t) unlimited
max user processes (-u) 900000
virtual memory (kbytes, -v) unlimited
file locks (-x) unlimited

Do you have some advice for this case? This error carry on appearing and if we perform a Google search, a lot of people are suffering with this same error...

Thank you!

Wagner Bianchi - +55 31 8654-9510
Profile: bit.ly/toG94v
Blog: wagnerbianchi.com/blog
Twitter: @wagnerbianchijr
Skype: wbianchijr

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: 1135 Can't create a new thread (errno 11)...
3643
December 20, 2011 08:51AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.