MySQL Forums
Forum List  »  Performance

Connections increasing at +10 per second with no requests
Posted by: Ian Young
Date: June 07, 2018 06:37PM

I suspect this is an out of control host process, but they're being very unhelpful.

I have a relatively straight forward Wordpress installation and I'm getting huge page loads of multiples of 30 seconds, always 30, 60, 90 and even more, sometimes up to 180 and 210 seconds. I often get Mysql went away errors, sometimes with max_user_connections errors, sometimes without.

After lots of digging to no avail, I ended up creating a staging site on a new database (different IP and port to the existing one, but within the same shared environment I guess) with no plugins enabled. I'm the only person who has access to the staging site, so I know exactly what requests are hitting the server and when.

My Connections are increasing at the rate of 10 a second without a single request. I'm now at over 580,000 Connections and the database has been up and running for a little over an hour.

Threads hover at about 15.

My Max_used_connections so far is 58 for some reason. I have only performed 3 or 4 page requests on the site and have now closed all tabs that could possibly access the staging site with hidden ajax requests etc. so I have no idea how I could have made it to 58 concurrent requests on my own.

Can anyone shed any light? Malware searches come up blank, at least within public_html.

Thanks

Options: ReplyQuote


Subject
Views
Written By
Posted
Connections increasing at +10 per second with no requests
47
June 07, 2018 06:37PM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.