MySQL Forums
Forum List  »  NDB clusters

ERROR 1114 (HY000): The table '#sql-46db_7' is full
Posted by: Frnck Geo
Date: February 09, 2012 03:54AM

Hello everybody,

I have no experience with MySQL Cluster...


1) I made a MySQL Cluster from 'mysql-cluster-gpl-7.1.18-linux-i686-glibc23.tar.gz' on operating system Debian 6.0.3.
I tested successfully test tables that use engine NdbEngine 'in-memory' and 'disk-based'.
So far all is well...


2) I imported successfully my database from SQL file (InnoDB and MyISAM tables) to a node.
This imported base countain big tables :

+----------+
| count(*) |
+----------+
| 31077584 |
+----------+
1 row in set (0.00 sec)

+-----------+------------+
| Table | Size in MB |
+-----------+------------+
| main_suiv | 3091.61 |
+-----------+------------+
1 row in set (0.09 sec)


My imported database is view in all nodes,
But by cons, the tables are listed only on the node that was used to import my database.
As all this is normal, so far all is well...


2) For using my new database with the cluster engine,
i used SQL command to alter tables :

ALTER TABLE main_suiv ENGINE=NDBCLUSTER TABLESPACE ts_1 STORAGE DISK;

After a while, an error occurs:

ERROR 1114 (HY000): The table '#sql-46db_7' is full

This is slightly the same error when I tried with tables in-memory!

Certainly I take it badly ...
How do I configure MySQL Cluster to import or build large tables and databases ?

Please, help me...
Thanks very much,
Sincerely.

Options: ReplyQuote


Subject
Views
Written By
Posted
ERROR 1114 (HY000): The table '#sql-46db_7' is full
6495
February 09, 2012 03:54AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.