MySQL Forums
Forum List  »  NDB clusters

Re: Failure to restore schema(Resource configuration error). Permanent error, external action needed)
Posted by: Parimal Patel
Date: May 14, 2014 02:04AM

The problem seems to be resolved after doing configuration changes in management node's config.ini file:

Diff is as given below (copied as is from logs):

-TimeBetweenWatchDogCheck=6000
+TimeBetweenWatchDogCheck=60000
-TransactionDeadlockDetectionTimeout=1200
+TransactionDeadlockDetectionTimeout=5000
-LcpScanProgressTimeout=60
+LcpScanProgressTimeout=300

------------------------------------------------------------------------------
Logs from mgmt node:
------------------------------------------------------------------------------

2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: CM_REGCONF president = 1, own Node = 1, our dynamic id = 0/1
2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: Start phase 1 completed
2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: Start phase 2 completed (system restart)
2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: Start phase 3 completed (system restart)
2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: Restarting cluster to GCI: 90112
2014-05-14 07:13:42 [MgmtSrvr] INFO -- Node 1: Starting to restore schema
2014-05-14 07:13:47 [MgmtSrvr] INFO -- Node 1: Restore of schema complete

------------------------------------------------------------------------------

Finally the schema was restored and it gave me great relief.

Options: ReplyQuote


Subject
Views
Written By
Posted
Re: Failure to restore schema(Resource configuration error). Permanent error, external action needed)
2103
May 14, 2014 02:04AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.