First of all, the output from ndb_mgm is showing that you have 2 data nodes running and connected to the Cluster
Quote
[ndbd(NDB)] 2 node(s)
id=3 @172.16.3.227 (mysql-5.6.17 ndb-7.3.5, Nodegroup: 0, *)
id=4 @172.16.3.228 (mysql-5.6.17 ndb-7.3.5, Nodegroup: 0)
That means that all available slots are being used and so attempting to connect any more data nodes will fail.
Looking at the command you're attempting to run to start a data node...
Quote
root@gngrmysqlnd1:/usr/local/mysql/bin# ./ndbd –-initial /etc/init.d/mysql.server start
2014-05-25 13:48:20 [ndbd] INFO -- Angel connected to '172.16.3.225:1186'
2014-05-25 13:48:20 [ndbd] ERROR -- Failed to allocate nodeid, error: 'Error: Could not alloc node id at 172.16.3.225 port 1186: Connection done from wrong host ip 172.16.3.229.'
... it looks like you're trying to connect a data node from 172.16.3.229 but you set up the config.ini file to only allow data nodes to connect from 172.16.3.227 or 172.16.3.228.
Quote
One more thing on the storage node, when i try to run root@gngrmysqlndb1:/etc/mysql# ndbd --initial -c localhost:1186
Unable to connect with connect string: nodeid=0,localhost:1186
Retrying every 5 seconds. Attempts left: 12
...in general, using localhost to specify hosts in MysQL connect strings isn't a good idea; try replacing it with 127.0.0.1
Andrew Morgan.
@andrewmorgan
@clusterdb
http://www.clusterdb.com