Failure of ndb_restore
So this is really fun... We've been using ndbcluster fine for years and we had a catastrophic event at the data center that ultimately caused power failure to everything.
Long story short is we couldn't bring data nodes back online "as is" because of REDO log corruption.
We decided to just restore a backup from a few hours earlier, and now that is failing as well (not outright, but all sorts of error messages... Some of the errors ndb_restore are producing are:
[NdbApi] ERROR -- Sending TCROLLBACKREQ with Bad flag
---------------
theNoOfSentTransactions = 1 theListState = 0 theTransArrayIndex = 5
---------------
Temporary error: 410: REDO log files overloaded (decrease TimeBetweenLocalCheckpoints or increase NoOfFragmentLogFiles)
---------------
Temporary error: 266: Time-out in NDB, probably caused by deadlock
---------------
Ultimately making the restoration of the database impossible and ending nbd_restore at some point into it with:
-----
...Unable to recover from errors. Exiting...
NDBT_ProgramExit: 1 - Failed
-----
I've tried single user mode, I've tried --parallelism=1 (it seemed to recover "better" from some of the errors when *not* using it).
Using the latest GA version (7.3.5) on SuSE Linux Enterprise 11.
Any assistance would be great... at this point we just need to get back online.
Subject
Views
Written By
Posted
Failure of ndb_restore
2143
May 27, 2014 04:06AM
Sorry, you can't reply to this topic. It has been closed.
Content reproduced on this site is the property of the respective copyright holders.
It is not reviewed in advance by Oracle and does not necessarily represent the opinion
of Oracle or any other party.