MySQL Forums
Forum List  »  NDB clusters

Re: unknown option '--ndbcluster'
Posted by: christophe DUMONT
Date: December 23, 2016 06:40AM

Hello,

Thks.
I installed mysqlcluster ndb-7.5.4 :
(wget http://dev.mysql.com/get/Downloads/MySQL-Cluster-7.5/mysql-cluster-gpl-7.5.4-debian8-x86_64.deb, dpkg -i mysql-cluster-gpl-7.5.4-debian8-x86_64.deb) and created the /etc/my.cnf file :

[mysqld]
ndbcluster

[mysql_cluster]
ndb-connectstring=192.168.56.101

When i run /opt/mysql/server-5.7/bin/mysqld start, i got the following error :

2016-12-23T12:39:51.067447Z 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit_defaults_for_timestamp server option (see documentation for more details).
2016-12-23T12:39:51.068323Z 0 [Warning] Can't create test file /var/lib/mysql/sql.lower-test
2016-12-23T12:39:51.076779Z 0 [Warning] Insecure configuration for --secure-file-priv: Location is accessible to all OS users. Consider choosing a different directory.
2016-12-23T12:39:51.077361Z 0 [Note] ./mysqld (mysqld 5.7.16-ndb-7.5.4-cluster-gpl) starting as process 1357 ...
2016-12-23T12:39:51.225346Z 0 [Warning] Can't create test file /var/lib/mysql/sql.lower-test
2016-12-23T12:39:51.225490Z 0 [Warning] Can't create test file /var/lib/mysql/sql.lower-test
2016-12-23T12:39:51.316521Z 0 [Note] InnoDB: PUNCH HOLE support available
2016-12-23T12:39:51.317186Z 0 [Note] InnoDB: Mutexes and rw_locks use GCC atomic builtins
2016-12-23T12:39:51.317639Z 0 [Note] InnoDB: Uses event mutexes
2016-12-23T12:39:51.318013Z 0 [Note] InnoDB: GCC builtin __atomic_thread_fence() is used for memory barrier
2016-12-23T12:39:51.318417Z 0 [Note] InnoDB: Compressed tables use zlib 1.2.3
2016-12-23T12:39:51.318931Z 0 [Note] InnoDB: Using Linux native AIO
2016-12-23T12:39:51.323460Z 0 [Note] InnoDB: Number of pools: 1
2016-12-23T12:39:51.347636Z 0 [Note] InnoDB: Using CPU crc32 instructions
2016-12-23T12:39:51.353411Z 0 [Note] InnoDB: Initializing buffer pool, total size = 128M, instances = 1, chunk size = 128M
2016-12-23T12:39:51.385674Z 0 [Note] InnoDB: Completed initialization of buffer pool
2016-12-23T12:39:51.390762Z 0 [Note] InnoDB: If the mysqld execution user is authorized, page cleaner thread priority can be changed. See the man page of setpriority().
2016-12-23T12:39:51.401470Z 0 [Note] InnoDB: The first innodb_system data file 'ibdata1' did not exist. A new tablespace will be created!
2016-12-23T12:39:51.401626Z 0 [ERROR] InnoDB: Operating system error number 13 in a file operation.
2016-12-23T12:39:51.401640Z 0 [ERROR] InnoDB: The error means mysqld does not have the access rights to the directory.
2016-12-23T12:39:51.401649Z 0 [ERROR] InnoDB: Operating system error number 13 in a file operation.
2016-12-23T12:39:51.401657Z 0 [ERROR] InnoDB: The error means mysqld does not have the access rights to the directory.
2016-12-23T12:39:51.401664Z 0 [ERROR] InnoDB: Cannot open datafile './ibdata1'
2016-12-23T12:39:51.401672Z 0 [ERROR] InnoDB: Could not open or create the system tablespace. If you tried to add new data files to the system tablespace, and it failed here, you should now edit innodb_data_file_path in my.cnf back to what it was, and remove the new ibdata files InnoDB created in this failed attempt. InnoDB only wrote those files full of zeros, but did not yet use them in any way. But be careful: do not remove old data files which contain your precious data!
2016-12-23T12:39:51.401919Z 0 [ERROR] InnoDB: InnoDB Database creation was aborted with error Cannot open a file. You may need to delete the ibdata1 file before trying to start up again.
2016-12-23T12:39:52.006754Z 0 [ERROR] Plugin 'InnoDB' init function returned error.
2016-12-23T12:39:52.007590Z 0 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
2016-12-23T12:39:52.007636Z 0 [ERROR] Failed to initialize plugins.
2016-12-23T12:39:52.007653Z 0 [ERROR] Aborting

2016-12-23T12:39:52.007705Z 0 [Note] Binlog end
2016-12-23T12:39:52.007829Z 0 [Note] Shutting down plugin 'MyISAM'
2016-12-23T12:39:52.042594Z 0 [Note] Shutting down plugin 'CSV'
2016-12-23T12:39:52.045612Z 0 [Note] ./mysqld: Shutdown complete

Options: ReplyQuote


Subject
Views
Written By
Posted
532
December 23, 2016 02:50AM
250
December 23, 2016 04:54AM
Re: unknown option '--ndbcluster'
357
December 23, 2016 06:40AM
354
December 23, 2016 10:47AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.