MySQL Forums
Forum List  »  NDB clusters

NDB Cluster binlog is enabled, and when I create a table, the server will execute for a long time
Posted by: MU Wei
Date: May 25, 2017 03:26AM

Hello there!

I'm using the MySQL NDB Cluster 7.5.5 Community Edition to build a new environment.
When binlog is not enabled, a table is created using the NDB engine, and the server executes 0.18 seconds,
When binlog is enabled, the server executes for a long time, and the more fields, the longer it takes.
If the engine uses innoDB, it's fast too.
Is there anything wrong with my configuration, or what important configuration is missing?

Management and SQL Node on Linux, data node on Windows


Thanks!


Here's my configuration´╝Ü

Management Node config.ini:
#
# Configuration file for MyCluster
#
[NDB_MGMD DEFAULT]
Portnumber=1186
[NDB_MGMD]
NodeId=49
HostName=192.168.0.117
DataDir=/usr/local/mysql-cluster/49/
Portnumber=1186
[TCP DEFAULT]
SendBufferMemory=50M
ReceiveBufferMemory=50M
[NDBD DEFAULT]
BackupMaxWriteSize=1M
BackupDataBufferSize=16M
BackupLogBufferSize=4M
BackupMemory=20M
BackupReportFrequency=10
MemReportFrequency=30
LogLevelStartup=15
LogLevelShutdown=15
LogLevelCheckpoint=8
LogLevelNodeRestart=15
DataMemory=512M
IndexMemory=90M
MaxNoOfTables=4096
MaxNoOfTriggers=3500
NoOfReplicas=2
StringMemory=25
DiskPageBufferMemory=64M
SharedGlobalMemory=20M
LongMessageBuffer=64M
MaxNoOfConcurrentTransactions=16384
BatchSizePerLocalScan=512
FragmentLogFileSize=512M
NoOfFragmentLogFiles=3
RedoBuffer=128M
MaxNoOfExecutionThreads=4
StopOnError=false
LockPagesInMainMemory=1
TimeBetweenEpochsTimeout=32000
TimeBetweenWatchdogCheckInitial=60000
TransactionInactiveTimeout=60000
HeartbeatIntervalDbDb=1500
HeartbeatIntervalDbApi=1500
[NDBD]
NodeGroup=0
NodeId=1
HostName=192.168.0.104
DataDir=D:/mysql/cluster-data/1/
[NDBD]
NodeGroup=0
NodeId=2
HostName=192.168.0.104
DataDir=D:/mysql/cluster-data/2/
[NDBD]
NodeGroup=1
NodeId=3
HostName=192.168.0.100
DataDir=D:/mysql/mysql-cluster/3/
[NDBD]
NodeGroup=1
NodeId=4
HostName=192.168.0.100
DataDir=D:/mysql/mysql-cluster/4/
[MYSQLD DEFAULT]
[MYSQLD]
MaxScanBatchSize=16M
BatchByteSize=1M
BatchSize=992
NodeId=50
HostName=192.168.0.117
[API]
NodeId=51
HostName=192.168.0.117
[MYSQLD]
[MYSQLD]
[API]
[API]

SQL Node my.cnf:
[mysqld]
character-set-server=utf8
datadir=/usr/local/mysql/data
basedir=/usr/local/mysql
socket=/tmp/mysql.sock
secure_file_priv = /usr/tmp
ndbcluster
server-id=1
skip-slave-start=true
log-bin=/usr/local/mysql/binlog/log-bin.bin
log-bin-index=/usr/local/mysql/binlog/log-bin.index
binlog-format=ROW
expire_logs_days=7
#gtid_mode=on
#enforce_gtid_consistency=on
[mysql_cluster]
ndb_connectstring=192.168.0.117
[client]
default-character-set=utf8
socket=/tmp/mysql.sock
[mysql]
default-character-set=utf8
socket=/tmp/mysql.sock



Edited 3 time(s). Last edit at 05/25/2017 08:29PM by MU Wei.

Options: ReplyQuote


Subject
Views
Written By
Posted
NDB Cluster binlog is enabled, and when I create a table, the server will execute for a long time
154
May 25, 2017 03:26AM


Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.