MySQL Forums
Forum List  »  NDB clusters

Re: "Got error 4009 'Cluster Failure' from NDB. Could not acquire global schema lock" and "Could not connect to storage engine"
Posted by: Barnabás Molnár
Date: October 10, 2017 02:45PM

Thanky you, but it turned out to be that the configs were good.

====== 1. problem, the ndb_mgm command - SOLVED:

I found out, that the MySQL API install (mysql-cluster-community-server) also installs the client dependency. That's why I can use the ndb_mgm tool from there, because it is in that package. So I installed the "mysql-cluster-community-client" package on the management node, and it finally works from there too.

====== 2. problem, the "4009 Cluster Failure error" - SOLVED:

Since it's an Oracle Linux 7.3, there is a Security-Enhanced Linux (SELinux) option. I set this to "disabled" and restarted the node:

[root@mysqlcluster-mgmt ~]# vi /etc/selinux/config
SELINUX=disabled

After I restarted the node and the MySQL service again, I used the ndb_mgm to list the nodes from the management node:

[root@mysqlcluster-mgmt]# ndb_mgm -e show
Cluster Configuration
---------------------
[ndbd(NDB)] 2 node(s)
id=2 @172.16.1.103 (mysql-5.7.19 ndb-7.5.7, Nodegroup: 0)
id=3 @172.16.1.104 (mysql-5.7.19 ndb-7.5.7, Nodegroup: 0, *)

[ndb_mgmd(MGM)] 1 node(s)
id=1 @172.16.1.101 (mysql-5.7.19 ndb-7.5.7)

[mysqld(API)] 1 node(s)
id=4 @172.16.1.102 (mysql-5.7.19 ndb-7.5.7)

Options: ReplyQuote




Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.