MySQL Forums
Forum List  »  NDB clusters

ndb cluster 7.4.12 seems to limit the number of tables/database to 50 when character set is utf8mb4
Posted by: George Mamalakis
Date: October 19, 2017 12:21AM

Hi all,

I've been trying to setup a mysql-cluster in SmartOS. The version in pkgsrc is 7.4.12. My setup has 1 manager node, 2 SQL nodes and 2 data nodes, all working properly.

When I tried to import my redmine database in the cluster, I kept getting the following errors:

ERROR 1114 (HY000) at line 879: The table 'xxxxxx' is full

no matter what tables I was creating, as long as their number exceeded 50.

`ALL REPORT MemoryUsage` was showing that my data usage and index usage was in 0%, which was very strange. After a lot of frustration, I decided to change my database's and its corresponding tables' character set from utf8mb4 to utf8. After that, importing worked as expeted.

Is that a known bug or limitation? Is it configurable? Because I'd like to use utf8mb4 instead of utf8 if I can.

Thanks all for any help/comments in advance!


Options: ReplyQuote

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.