MySQL Forums
Forum List  »  NDB clusters

Re: SQL node not starting
Posted by: Shaun van Wyngaard
Date: November 29, 2017 06:19AM

Hi Jon

Thank you for taking the time to assist me.
Yes, with regard to the warnings about the gtid table, I tried to find some specific info on it, to no avail, so I am glad you commented on that.

When I run the command "mysqld --initialize --user=MySQL", the problem was that it would run 10-15 seconds, and then put me back at the command prompt. So it didn't "STAY" running. So I'm not sure if this is a once off command. Without me then subsequently clearing the /data folder before trying the command again, it would give a message about there already being files in that /data folder, and then abort. So I took a chance, and without deleting those files, I left them there, then re-ran the command again but now removing the --initialize part from the original command, and now it stays running!
I can see in in the process list in Task Manager, and I can also see it on the management node when I issue a "show" command.
So I guess it is now working.

Thanks again, and I really hope that this helps someone else.

Options: ReplyQuote

Written By
November 28, 2017 04:20AM
November 28, 2017 05:57AM
November 28, 2017 07:40AM
November 29, 2017 02:06AM
Re: SQL node not starting
November 29, 2017 06:19AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.