MySQL Forums
Forum List  »  NDB clusters

MySQL Cluster on Docker Swarm
Posted by: Jascha Brinkmann
Date: May 01, 2018 01:58AM

I am struggeling to get this to work following the outline in this topic and bug report:,658482,658903

I get an error `Unable to lookup/illegal hostname mysql_data1`

Do you have to add the `endpoint_mode: dnsrr` directive to each service?

Even if I add it to each service it still doesn't work.

If you deploy the services from a stack file docker automatically adds the stack name in front of the service name. But even having that in mind I still get the same error `Unable to lookup/illegal hostname`.

The Docker Hub Readme hasn't been updated with info about this, so it would be incredible helpful if someone got a working compose/stack file.


Options: ReplyQuote

Written By
MySQL Cluster on Docker Swarm
May 01, 2018 01:58AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.