MySQL Forums
Forum List  »  NDB clusters

Re: Mysql NDB cluster - Big import fail
Posted by: Ted Wennmark
Date: June 01, 2022 03:13AM

Hello Cesar,

Sorry to hear you are having problems importing your dumpfile.

mysqldump uses large extended inserts by default, this is most likely the problems you are facing. This works for InnoDB but NDB is not that good with large transactions.

You can work around this by creating a new dumpfile. You have 2 options, either remove extended inserts completely:
mysqldump --extended-insert=0
Or you can set "net_buffer_length" to control the size of the extended inserts:
mysqldump --net_buffer_length=4096

I would try to set net_buffer_length=4096 and re-run the import.
You can run a grep to see how many inserts are created: grep -c INSERT slabb.dump

As Jon suggested, another options is to first import data into InnoDB and then run alter table and set engine to NDB.

Have a good day!

Kind Regards,
Ted

Options: ReplyQuote




Sorry, only registered users may post in this forum.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.