MySQL Forums
Forum List  »  NDB clusters

cluster upgrade problem
Posted by: Arnaud Abélard
Date: April 11, 2006 02:20AM


I wanted to upgrade my cluster nodes from mysql-max 5.0.18 to mysql-max 5.0.19 to resolve some (minor) problems i exposed in a previous messages.

on each node:
- i shut down mysqld and ndbd
- copied the data dir from 5.0.18 in the 5.0.19 folder
- put back the right ownership and permissions on the data folder
- restarted ndbd and mysqld

It worked fine on the first node (ndbd started, mysqld started, both showed up in the management console)
It worked fine on the 2nd node (ndbd started, mysqld started, both showed up in the management console)
But when i started the 3rd node, the mysqld processes were not showing anymore in the management console.. i tried a few <mysqlid> start but got the following error:
ndb_mgm> 7 start
Start failed.
* 22: Error
* The process has wrong type. Expected a DB process.

I didn't change _anything_ in the configuration files at all.. just upgraded the mysql distribution and the cluster was starting properly before that.

i logged on the different nodes, restarted both ndbd and mysqld, they restarted fine but only the ndbd processes showed up in ndb_mgm after few minutes i got the following error in the management console:
ndb_mgm> Node 2: Forced node shutdown completed. Occured during startphase 4. Initiated by signal 0. Caused by error 6303: 'Unable to find a restorable replica(Ndbd file system inconsistency error, please report a bug). Ndbd file system error, restart node initial

any idea what went wrong?

Options: ReplyQuote

Written By
cluster upgrade problem
April 11, 2006 02:20AM
April 11, 2006 10:41AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.