MySQL Forums
Forum List  »  Replication

Re: Replication crashes when max_bin_log_size is reached
Posted by: Pär Iwarson
Date: April 30, 2005 09:45AM

Yes, you seem to have the same problem. And I'm sorry to say but we have still not been able to find a solution for the problem. :/

Currently I have to monitor the database and when the relay log size almost reach the max_bin_log_size limit I have to do like this:

3) Restart mysqld.

This way is the only way we can make it work and get mysql to rotate the relay log. But it's very annoying and as our business is growing we have to do this more frequently. Currently we have to do this almost 2 times a week. :(

I have tried pretty everything I can think our. I can't be permission problem cause I have tried with all permissions. But I have no longer any idea of what can be the cause of the problem and I have run out of ideas for a solution.

What version of MySQL do you use? What platform do you use?

We use MySQL 4.0.23 and RedHat Linux 2.4.22-1.2149.nptl and we also have ensim running on the server.

It seem to me that it's either a bug in MySQL or a bug in RedHat Linux. Our Master database run the same version of MySQL but with FreeBsd Linux instead and it has had no problems with creating new bin-logs. But I guess it's another deal with the relay logs.

If you manage to solve the problem I'm very interested in knowing how :)

Options: ReplyQuote

Written By
Re: Replication crashes when max_bin_log_size is reached
April 30, 2005 09:45AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.