MySQL Forums
Forum List  »  Replication

Problem setting up replication
Posted by: Marcel Vijfwinkel
Date: July 10, 2007 03:10AM

I'm trying to setup replication, but I get the following error after I restart mysql on the slave:

070710 12:48:17 [Note] Slave I/O thread: connected to master 'replication@85.17.x.x:3306', replication started in log '/var/log/mysql/bin.log' at position 4
070710 12:48:17 [ERROR] Error reading packet from server: Could not find first log file name in binary log index file ( server_errno=1236)
070710 12:48:17 [ERROR] Got fatal error 1236: 'Could not find first log file name in binary log index file' from master when reading data from binary log
070710 12:48:17 [Note] Slave I/O thread exiting, read up to log '/var/log/mysql/bin.log', position 4

There is a bin.index and a bin.000001 file in /var/log/mysql/ on the slave
The contents of 'bin.index' is 'bin.000001'
'bin.000001' is about 13Kb in size


my.cnf on the master:

server-id = 1
log-bin = /var/log/mysql/bin.log

my.cnf on the slave:

server-id = 2
master-host = 85.17.x.x
master-port = 3306
master-user = replicant
master-password = xxxxxx

log-bin = /var/log/mysql/bin.log
log-error = /var/log/mysql/error.log



The strange thing is that when I change settings on the slave (for example the master-user) in /etc/mysql/my.cnf that mysql seems to ignore these when I restart. When I use the mysql command shell it does correctly update these settings. Is there another config file where these settings are stored, or are these stored in the db itself?

Any suggestions would be very much appreciated!

Options: ReplyQuote


Subject
Views
Written By
Posted
Problem setting up replication
3085
July 10, 2007 03:10AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.