MySQL Forums
Forum List  »  Replication

Replication fails on slave (missing relay log)
Posted by: Armand Krijgsman
Date: July 02, 2008 02:14AM

Hi All,
After brainstorming and trying for a day now I need to request for a solution here. After a software update on my debian etch system, mysql needed a restart. When I wanted to restart the slave I however get the following error:

#29 - File '/var/log/mysql/relay.001427' not found (Errcode: 2)

When I look into my mysql log directory I índeed do not have this file.
Is there any way to clean this up and start a fresh replication from the data on the master?

Master Status:
10.0.0.1
File Position Binlog_Do_DB Binlog_Ignore_DB
mysql-bin.000817 4439412

Slave status:
Slave_IO_State
Master_Host 10.0.0.1
Master_User replication-user
Master_Port 3306
Connect_Retry 60
Master_Log_File mysql-bin.000816
Read_Master_Log_Pos 14682103
Relay_Log_File relay.001427
Relay_Log_Pos 4
Relay_Master_Log_File mysql-bin.000816
Slave_IO_Running No
Slave_SQL_Running No
Replicate_Do_DB
Replicate_Ignore_DB
Replicate_Do_Table
Replicate_Ignore_Table
Replicate_Wild_Do_Table
Replicate_Wild_Ignore_Table
Last_Errno 0
Last_Error
Skip_Counter 0
Exec_Master_Log_Pos 14435444
Relay_Log_Space 0
Until_Condition None
Until_Log_File
Until_Log_Pos 0
Master_SSL_Allowed No
Master_SSL_CA_File
Master_SSL_CA_Path
Master_SSL_Cert
Master_SSL_Cipher
Master_SSL_Key
Seconds_Behind_Master NULL

Any insights would be very much appriciated!

Kind regards,
Armand

Options: ReplyQuote


Subject
Views
Written By
Posted
Replication fails on slave (missing relay log)
6781
July 02, 2008 02:14AM


Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.