MySQL Forums
Forum List  »  Replication

Re: Can't start slave using master replication coordinates
Posted by: Eric Coll
Date: April 27, 2012 10:42AM

The replication has been running for a long time, so it has been setup correctly.

After the master failed, the client will not connect with the mentioned error.

We tried the following:
1. Stop slave
2. Lock master to read only
3. backup master to slave
4. Reset master
5. Get master replication coordinates
6. reset slave
7. run change master on the slave with the above coordinates
8. start slave
9. show slave status

We still get the exact same error on the slave:
master error: ‘Could not find first log file name in binary log index file’

Options: ReplyQuote

Written By
Re: Can't start slave using master replication coordinates
April 27, 2012 10:42AM

Sorry, you can't reply to this topic. It has been closed.

Content reproduced on this site is the property of the respective copyright holders. It is not reviewed in advance by Oracle and does not necessarily represent the opinion of Oracle or any other party.